Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Kafike

Members
  • Posts

    479
  • Joined

  • Last visited

Everything posted by Kafike

  1. 1989 Eagle/Renault Medallion. Come to think of it, I haven't seen another of that car since mine.
  2. I checked my MPG the other day. I'm only hitting 11 MPG. Horrible, but my O2 sensor is bad.
  3. Interesting. I've thought about trying a cabin filter but never bit the bullet on it. I'm kinda tired of getting dirt in my face everytime I turn on the blower. Wind and desert living make for lots of dirt in the ducts.
  4. I bought a cobra 75 something. Everything is contained in the handset/mic thing (I know, technical terms lol). Just has a little box to mount that it plugs into. I mounted the box under the Driver's side of the dashboard, Just to the left of the radio and keep the mic in the center console for when I need it.
  5. Transmission got flushed. Shifts a lot better now.
  6. You must be landing awfully hard! Nothing on mine today. Just driving it.
  7. Not much. Took it the gas station and met another gut with a Pathy he was working on also. Nice!
  8. Hey bud and welcome. I can't answer most of the questions as I haven't done my swap yet. New motor is on the engine stand (1996 Pathfinder motor) but this has been documented here by many. Mr.510 sells an adapter to make it plug and play (the motor). I know there is some work with the oil pump pick up tube and possibly on the brackets for the accessories. Don't remember at the moment though. Nefarious has done this swap on a couple of rigs. Maybe he will chime in but search and you will find
  9. That's pretty awesome, Nefarious. Waiting to see what you come up with. I don't even know where my front skid plate is anymore . I took it off years ago for some reason. wasn't very useful anyways. Changed my oil, cleaned the MAF and fixed a broken exhaust hanger. No more exhaust banging around on the trans cross member and the motor seems to respond a bit better. Still need to do the O2 sensor. It just doesn't want to budge.
  10. Damn o2 sensor will come out, one way or another lol. Still need to clean the MAF. Motor runs smooth now, though rich, because of the O2 sensor. I replaced a bunch of vacuum lines but may have missed one or two.

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...