Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

'87 xe-v6


asantos
 Share

Recommended Posts

My 87 3.0 manual 4x4 pathys dash lights will go on as I initially brake. Kind of like when you first turn the key in the ignition. I imagine it's something eletric? If anyone has had this issue and knows what's going on I'd greatly appreciate any information. Thanks guys. 

Link to comment
Share on other sites

There's an odd one. So the idiot lights are coming on, not the backlight? I'd have to have a closer look at the wiring diagram but all I can think of is that you've got a weak ground or something that's limiting power to the dash when the brake lights are on and making it revert to the bulb check when you first turn the key. Do your brake lights work?

Link to comment
Share on other sites

Thanks for the reply, yes my brake lights work fine and not too long I cleaned the wiring connection specifically the ground to the engine block as it was giving me serious electrical issues like misfiring and shutting off while running but haven't checked it since. Should I run through the wiring again and make sure all is well there? 

Link to comment
Share on other sites

Might be worth checking the main body ground (where the ground strap to the engine bolts up between the battery and the engine), but if that was the problem I'd expect it to cause more trouble than what you're seeing. I'd be less surprised to see a flaky fuse link or something, but again I'd be surprised if your weird dash light issue was the only symptom of that. Might be worth just having a look around the brake pedal for anything loose/damaged/rewired by a tweaker with a handful of crimp connectors and a vague idea of what they were doing and left hanging to rub against the brake pedal.
 

I have an '89 service manual but it doesn't have the full wiring diagram, just individual diagrams for each separate system, so that makes it a bit tricky to track down where the two systems might meet up. Let me know if you get stuck and I'll have a look at the full diagram for the four-door and see if anything jumps out at me. One thing you might try in the meantime, pull the 10A fuse for your brake lights (looks like it's fifth from the left on the bottom row, should also be marked in the fuse box though) and see if the idiot lights still come on when you hit the brake pedal.

Does your '87 have cruise control?

Link to comment
Share on other sites

  • 2 weeks later...

I have a 1988 4x4 2 door and I have the same issue with the dash lights coming on when I step on the brake.  Also having trouble with the high beam working on the driver side.  I do not know if the two are related.

Link to comment
Share on other sites

  • 2 weeks later...
On 12/17/2018 at 5:32 AM, chen2761 said:

I have a 1988 4x4 2 door and I have the same issue with the dash lights coming on when I step on the brake.  Also having trouble with the high beam working on the driver side.  I do not know if the two are related.

 

Your headlight problem is likely covered in the following thread

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...