Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

spicyheckboi

Members
  • Posts

    185
  • Joined

  • Last visited

  • Days Won

    5

Everything posted by spicyheckboi

  1. Nowwwww im done. [emoji106] Sent from my LM-G710VM using Tapatalk
  2. Nowwwww im done. [emoji106] Sent from my LM-G710VM using Tapatalk
  3. Nowwwww im done. [emoji106] Sent from my LM-G710VM using Tapatalk
  4. Not done yet but how bout that Sent from my LM-G710VM using Tapatalk
  5. These should be better quality, the others posted as pixelated for me for some reason Sent from my LM-G710VM using Tapatalk
  6. Updated pics as of this morning. I love my r50 Sent from my LM-G710VM using Tapatalk
  7. Part of the reason ive been awau for so long is due to working on my partners 4.0 wj. Front coil perches were GONE but at least that's the only rust on the truck. It sits with stock size 235/70/16 and 2.5 inches of lift. I did it all with rustys off road stuff, springs, shocks, adjustable track bar, coil perches. Heres alsp the brackets i cut out for the bumper and the bumper itself. I also got new front wheel bearings amd brakes all the way around, my front rotors were SO WARPED. talk about a shimmy in the steering wheel ugh... On top of that when i took apart the rear drums there was missing pieces and ive basicqlly been running with no rear brakes, at least on the left. What a difference in nose dive during braking now my goodness, it stays mostly level, and getting the top end drilled and slotted rotors from advance was a good choice for me, theyve been holding up great and wont warp on me for much much longer Sent from my LM-G710VM using Tapatalk
  8. Their issue was that bolts were already broken off, plus i had snapped one taking off the driver side so i ended up leaving them off. Lately i have been thinking about how i miss them though, i might still get ahold of a set to throw on. Near me and the people i go wheeling with we all have cbs, i have been neglecting my account here on progress... Ham radios are 100% cooler, my cb is basically just trail use anyway though. I now have a cb installed, finished painting the black stripe all the way around and trimmed the front fenders evenly (fricken FINALLY) i dont want to do the sfd, this setup handles better than my mk4 golf, so i trimmed off 3/4 of an inch around the wheel well to let it sit better me, ill have to post some new pics Im currently in the process of building a rear bumper now too. Sent from my LM-G710VM using Tapatalk
  9. Looking awesome [emoji106][emoji106][emoji106] Sent from my LM-G710VM using Tapatalk
  10. Exactly [emoji106][emoji106][emoji106] Sent from my LM-G710VM using Tapatalk
  11. I got to get into the woods near big flat brook near me I need a wing person to film stuff, I wish I could've gotten video of the creek bed I found.. Rocks are fun and nothing has stopped this truck so far so I need to go to rausch creek Sent from my LM-G710VM using Tapatalk
  12. I can't say that thought hasn't come across my head too. Do you also have manual hubs up front? Sent from my LM-G710VM using Tapatalk
  13. Lmao you'll definitely get done before me Sent from my LM-G710VM using Tapatalk
  14. Sadly they're on the way out too, and the rear wheel bearings are one that looks a little more like a can of soup if I remember right , while the front do a sandwhich of two bearings per side inner and outter. The brake issue for you- do you have manual locking hubs in the front? It made a huge difference in braking after I had those on because of the less rolling resistance they provide. But also I think there's a cylinder for the rear too i thought I saw online when I was looking at rear drum kits for us Sent from my LM-G710VM using Tapatalk
  15. Lmao same!! I have pads and rotors in a box in my room with a cb radio waiting to go I just need to get the bearings, I just came home and the rears started to squeek now ugh Sent from my LM-G710VM using Tapatalk
  16. That's what I'm gonna be doing. The alignment shop told me they thought it might be warped last time I got it done maybe month and a half ago but I let it slide because I know my pads are okay, but since you're "in the area" ya know? Either way I'd expect a warped rotor to mess some bearings, so doing both should keep it from happening again I hope. All hoping its the cause of our symptoms lol Sent from my LM-G710VM using Tapatalk
  17. Yep I have the same symptoms showing up on mine over the past month or so getting worse, when it first started I thought it was just warped rotors which they still could be warped but I definitely am gonna try the bearings too. Gotta take it down that far at some point to do my rotors anyways ¯\_(ツ)_/¯ Sent from my LM-G710VM using Tapatalk
  18. Just curious, when you hear that sound do you feel vibration in your steering wheel as well or is it just the sound to look out for? Sent from my LM-G710VM using Tapatalk
  19. Sorry its taken so long but that's 1/4 inch Sent from my LM-G710VM using Tapatalk
  20. I already got out fishing this year! Didn't catch anything though... Lmao Sent from my LM-G710VM using Tapatalk
  21. Agreed! on all ends Sent from my LM-G710VM using Tapatalk
  22. Just to clarify i said what i said from going up over logs to get up a hill. It idles up to the obstacle hits and stops. I smoothly accelerate over the obstacle from the stop with no issue of lurching or seeming like i dont have control. We dont have the gearing or power to just idle over things bigger than half the tire. Dont get rid of ur rig just build it the way you want it Sent from my LM-G710VM using Tapatalk
  23. So i got to get into 4lo when i went off roading near the beach in south Jersey the other day. I still have smoothness and not expiriancing what you guys are. Im an 03 with the drive by wire, but i also did just change every fluid but diffs and coolant, and i had all od my toolsbin the truck so it was pretty heavy too, maybe the weight makes it work better? Idk why i wouldnt expiriance the same as you guys unless its that or maybe the big aggresive tires ?? But when i am in 4L and gently get on the pedal i get immediate response that isnt lungy or kicking in at a higher rpm like that Idk maybe my r50 is just weird Sent from my LM-G710VM using Tapatalk
  24. Two days ago went down to south Jersey for family and to have fun near the beach here's a video of a little couple puddles. Then today drive up to port jervus to the hawks nest. Both nice drives and these rures kick ass in the sand and water. Sent from my LM-G710VM using Tapatalk
  25. Just had every fluid changed but coolant and diffs I'm a happy camper Sent from my LM-G710VM using Tapatalk

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...