Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

95 Pathfinder. Temp Gauge and Engine Thermal Signal


Dragster
 Share

Recommended Posts

Having problems with the Temp Gauge not working. I have replaced the sender at the coolant outlet, checked continuity (ohms) on the single wire from the sender plug to the instrument cluster (0 ohms), ran wire from the 'B' Lug for Temp gauge to ground, needle moved. But gauge still doesn't work. Also have problem with the Thermal Temp Sensor for the ECM. Checked the 2 wires for continuity (0 ohms), cleaned all connectors. the engine has a slight backfire through the exhaust when decelerating and all trouble-shooting sources indicate the Thermal sender. It's been changed also for a new one. All suggestions welcomed, thanks.

Link to comment
Share on other sites

  • 2 months later...

There is a voltage regulator that powers the gauge. Check input and output voltage of the regulator to ground. Should be battery voltage in and 8 volts out with the key on.

Link to comment
Share on other sites

If I ground the wire from the sender, the gauge goes all the way to hot. Is this the same thing. My fuel gauge works fine. How hot in F° should the coolant be running at when at optimal temperature?

Link to comment
Share on other sites

Are you grounding the sensor wire in the engine by the sensor, or at the other end in the cab?

 

The gauge grounds through the sensor. If you ground the wire at the sensor and get full hot on the gauge, then I would bet your sensor is bad. At operating temp the sensor should ohm to ground around 30-40 ohms. If it doesn't, bad sensor.

 

Temp depends on your thermostat, but around 170-195.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...