Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Mr. Pickles

Members
  • Posts

    5,158
  • Joined

  • Last visited

Everything posted by Mr. Pickles

  1. I am fully aware this has been beat to death. I have a 94 WD21, + a couple little kids, 3 vehicles and house that eat any "free" time. Anybody know which Ford coils fit? I am actually trying to lose an inch of lift or so (also have a 3" body lift, the old "3+3" lift). I seem to remember late 70's F150 front coils. I have been running JGC coils for 10 years now, but want something stiffer for towing and such. I got a hall pass from the wife to hit the junkyard in the am, so time is of the essence.
  2. Thanks guys. I'll see if I can figure out a long enough driver but with big enough head to get that last screw. There isn't a straight shot to be had on my rig, and this is one of a few steps either left out of the FSM and Haynes manual, if not totally contradicted. I think I might have a Frankenpathy.
  3. Tell me I'm crazy, but do you really have to remove the distributor to get at the last forward screw to pull the cover on the driver's side of a VG30 (94 Pathfinder)? This is getting ridiculous, I'm wrapping up a water pump and timing belt, and figured I'd better replace these leaking gaskets, but the design of this thing is a joke.
  4. Nunya, do you have info on GrandpaX's panhard bracket? About 2 to 2 1/2" suspension here since I cranked it down, formerly cranked to 3," along with 3" body. I did quick search attempt, and didn't see anything. I wonder if this would finally cure my rig. Nobody suggested something like that after the lift years ago, then I put in a rear locker and have run the setup for 6-7 years or so. I went back and replaced the upper rear links from the junk yard a year ago or so, after the bushings where toast and I had a TON of slop in general in the rear. The lower links and bushing still feel tight, as does the panhard link, but I've always had a kinda harsh side-too-side torque pull upon shifting or hitting the go pedal, which I've been battling for a bit. I put in new shocks last summer, along with sway bar links and bushings, which helped a bit. I could imagine the geometry change could twist things up a bit easily for the panhard after lift and lock, now that I think about it. LOL the learning curve. I've only rolled this thing 10 years now.
  5. Anybody that's also has an aftermarket alarm on theirs, what brand do you have? I'm just curious, I want to say mine is 90% Viper, though possibly Clifford, but I've had a mix on different vehicles.. It definitely doesn't have ignition lock/kill, as I had an issue years ago and ended up driving through the neighborhood at 6am with the alarm blaring. Sorry for no actual feedback so far, my brother has been borrowing the rig this week along our utility trailer, but soon. Thanks for the feedback.
  6. I don't really care about the alarm at this point if i can figure it out cheap/free. it's an almost 20 year old rig with old stereo equipment I that I really crank and can't listen to with the wife and kid along, only when I'm driving it alone once a month or so. It's just the lights issue that makes it a deal breaker. I hope to have some time to spare over the next week/month or 2 to figure it out before the baby comes.
  7. Yes to being an aftermarket alarm, but once a door is opened, the clicking/lights will start up and continue, independent of if a door is open, except for the driver's side rear door. That one seems to reset the clicking cycle when it's opened/closed, so that might be a sign. The clicking is quite loud and a regular cycle - click on, off, in rythym,, and you can hear it inside and out easily, which it's never done before except for when arming or disarming the alarm, which brings me back to the "brain.". I've owned this thing going on 10 years, so I know what is "normal," or at least normal from my old beast. A couple of the door switches are in rough shape, though I don't recall if that one is too, so I might try swapping some/all. The driver's door switch has been iffy for years, and the hinge pins are toast so it sags a bit, but closes firmly. Also, the exterior lights stopped flashing for the alarm years ago, I'd bet 5 years at least, and it's been dead almost entirely for the most part for a few years. It's my play rig, so it spends a lot of time parked these days, and of course new issues seem to show up each time I pull it out and start it up. Maybe I'll just disable the alarm at first, and see if taking that out of the equation solves things. Fun.
  8. I've got a weird one, again, an electrical gremlin... again.. Is there a relay or something in the center of the dash/firewall area related to the doors and interior lighting on a '94? My after-market alarm stopped working a couple years ago, no biggie, there's nothing important to steal, but that was my first clue (thought it randomly worked a couple times since then). The front door light "switches/buttons" on the body have been in rough shape for a while, not sure if that is a factor. Suddenly there is now a clicking sound, almost like a turn signal continually clickinging on and off, but pretty loud, coming from the center of the dash and/or the firewall under the hood. I happens once I open the door, regardless of key in or out of the ignition or turning it to different positions. You can hear it fairly loudly both from the interior, and from outside/under the hood, but I haven't been able to pinpoint it. The interior lights will click on and off to it, over and over. It will happen randomly for a few minutes, several minutes, stop, start up again, etc.. One time, the alarm started acting up and turning on while refusing to turn off. In the end, it eventually shuts off, but it's irritating as hell. I've got a 2 year old, another on the way, and a few other projects, so finding time to track this down is a problem. Just wondering if this ring any bells. Initially, I'd be thinking the alarm is junk, but the door and lighting issues point me toward the Pathy itself.
  9. Hey guys, sorry for being MIA, work/kid/life/yadda yadda. I'm out, unfortunately. It kills me, cause Evans is literally RIGHT in my back yard. It's our anniversary, and will be the first out of town, no-kid weekend in a couple years, and probably the last for a while (kid #2 is due last week of Feb/1st week of March). The rig is getting in great shape finally, I just don't have time or a ton of cash to wheel it a lot lately. I put on new rear Pro Comp ES 9000 shocks in back (fronts are on the way but on back order), and a bunch of other little stuff, new headlight housing, etc., and the new (used) steering box/gear just arrived today, ready for install this weekend. I'ts also got low miles on new center link, ball joints, tie rod ends, sway bar links, bushings......... My junk will be back in prime shape for winter, but I'll have to miss you guys on the run (again!). Keep the rubber side down, and have a blast. Mr. J-1&2 vet!
  10. I have to chime in as no-go as well. A combo of 1 year old baby/new job/ Etc. has me throwing in the towel. I hope you guys have a blast, and I hope to catch you next year!
  11. Ok, call me confused, but is there an actual trail route/plan to the run, or start here/end here? I'm from the Western WA side, the Enumclaw/Buckley/Bonney Lake area, which has come up. From here, the Naches Trail (Sumner-Buckley Hwy) is literally 1 block from my house, and you can follow that off road, or Hwy 410 over to the Yakima Valley. But it sounds like people are starting somewhere in Cle Elum area at the Safeway (I know it, right off I-90). I'm just trying to nail down logistics. While it doesn't sound like much online, the little details do, as it can add 100+ miles, as has been discussed. If you look at a large area map, we're talking about a big triangle - Seattle/Tacoma area, Cle Elum/Ellensburg, and Yakima. Has there been a solid start/finish line discussed? *please don't kill me for READ ABOVE!* I'm exercising limited online time with baby in-house. Its just that depending on the direction you're coming from vs ending from, it can make a big impact.
  12. I'm in. Sorry, I might have missed it, but where are folks looking to meet up over there? My bro-in-law wants to ride along. They live in Yakima, over Hwy 410 from here in Bonney Lake, and to the south of the off road area AFIK. A map or some landmarks would be helpful for planning. I'm liking the scenic route mentioned, especially if there are harder turnouts for those that choose. People coming from far and wide, choose your poison.
  13. Well... both Kyle's!!! Just make it so!
  14. Kyle, just get your *rear-side* over there. Enough said.
  15. Mananstash looks fun, if there are bypasses for some of us if it gets hairy. Neither a winch nor sliders are in the budget anytime soon here.
  16. Ready to build an ark. Rain, rain, go the F away...

  17. Hey man, long time indeed. Sorry, just noticed your message, I haven't used that tool yet. I've been kinda MIA here lately, made a few runs, but got a baby around these days = not much play time. Hope to cya around soon and meet up.

  18. Agreed, I had similar issues and found the upper link bushing were toast. While still bolted in, the lowers had a slight flex if you tried to twist them by hand (I'll probably change them out soon enough too), while the upper short ones moved visibly many, many degrees of twist just by hand, and the driver's side was much worse than the passenger side. The rig would really pull/twist to the side when accelerating on the highway, and at speed going downhill, the rear end was even worse and would sway and be SUPER sloppy. I swapped them out probably 2 months ago (there's a post on here) with some new-to-me arms from a gently used wrecked Pathy at the junkyard rather than replacing the bushings, problem solved quick and cheap for $20. I also swapped out the swaybar bushings and rods with a new kit for like $20 from eBay. I have a rear Lock Right locker, so the problem was even more pronounced on mine, kinda scary really. Anyways, good luck!
  19. My 94 has a weird gremlin. The AC and cig lighter will randomly work, say 80% of the time. The last few days, however, they didn't work at all. Not good with temps in the 40's and 50's and pouring rain (need AC to clear the foggy windows). This has been on-going, and usually a hard smack to the dash right where it sticks out between the gauge cluster and middle air vents does the trick. I pulled the center dash trim around the HVAC and stereo again tonight, but didn't do much other than pull out and move some wires, and it started working again. I know they apparently are on the same fuse, which checks out fine, and I've searched other threads but its usually an issue of them not working at all, not just intermittently like mine. Does anybody know if they are wired in series or something, or where there may be a common wire/plug/ground in the area? I've got the service manual in pdf, but it isn't too clear. I say it must be a loose connection in the vicinity, though I've checked out the plugs to the cig lighter and such, and cleaned and used dielectric grease. I'm thinking something farther inside the dash, but who knows. I haven't spent much time with the AC switch and such, that might happen again tomorrow. Anyways, thoughts?
  20. I'll throw my hat in as "maybe." I've never wheeled Elbe, but have heard some nasty stories. Considering its my daily driver rig, I'll vote with the mild guys.
  21. Hey all, I took the liberty of starting a pics thread. It was a good day! Till next time... Pics linky
  22. Ok, I'm in last minute. Negotiated me-play tomorrow, me watch little one and she-play Sunday. Possibly +1 with my brother riding along. Did I hear CB channel 4?
  23. Well, double shoot. I spaced that we were already set to go to Ocean Shores with a group of friends Sat. for the razor clam dig. I'm kinda sketchy on that though, since we're leading the group of newb's, they're talking cold temps and we've got an almost-6 month old baby. Let me see what happens with the weather report and the wifey report.

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...