Jump to content
jolut

Low engine temperature

Recommended Posts

I have a problem with low engine temperature in my '88 terrano.
A few weeks ago, I installed a new thermostat and it worked fine. Until recently. The needle hardly move now, especially when I turn the heat on.

I changed the thermostat because of to hot engine. But can this be a faulty thermostat again? 

  

Share this post


Link to post
Share on other sites

Certainly sounds like it is sticking open. You are probably going to have to take it apart again.

You can’t test it by putting it in some boiling water and look to see if it opens and closes.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I've heard of "fail safe" thermostats that lock themselves open if engine temp goes above a certain point (and tend to lock up for no good reason). Seems odd that a new thermostat would've failed already otherwise. I'd want to check the temp sensor and the temp gauge before taking it all apart again.

Share this post


Link to post
Share on other sites

If you can get an OE Nissan one, go that route. The after-market ones always seem to be * * * *.

Share this post


Link to post
Share on other sites

Cant find any problems except for the thermostat sticking open.
I installed a new one, another brand, today.
Will use the car tomorrow 😀

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Welcome to NPORA Forums

 

Please REGISTER to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×