Jump to content
Sign in to follow this  
nick9871

wtf negative camber from lift?

Recommended Posts

Rocky 2 had a thread on the subject, if you want to get flamed you can search for it or if I can get my fat arse away from the TV I'll try to find it for ya.

 

All I came up with was his reference here but no post:

Share this post


Link to post
Share on other sites

Essentially, just buy a die grinder and slot the upper hole towards the strut tube. You won't need much, maybe 1/4-3/8" before you will lock the spindle to the strut tube and can go no further with the adjustment. I slotted mine WAY more than I needed, by about 3/8", but it doesn't really make a difference as I am locked to the strut tube and the bolt hasn't moved on me yet.

Share this post


Link to post
Share on other sites

Ok NPORA family, dusting this thread off to show that I DID try to research my issue before posting a new thread, but I still would like more current input from the pro's on here.

The pic is kind of hard to tell, but my passenger side has developed a slight negative camber. It occurred after an off road adventure awhile back.
Another issue worth noting is that when I took the front spacers off and drove it, the steering became increasingly erratic. Very much like the lower ball joint not being intact causing random pull. With the spacers on, this specific issue is not a concern.
Not sure why the spacers matter with this issue.
The steering has become more loose overall and has a slight "wiggle" in the steering wheel, hence why I'm doing a complete steering/suspension overhaul of original parts.

To the question at hand, based on your experience do you think I bent my strut when wheeling?
Are there any other things that I should consider before forking out for a new strut assembly.
And since I will already be doing a complete overhaul of the entire front suspension already. Are there any brands that would be better than others for replacement parts?

Thanks in advance for any insight provided!ac5c5d103d1cae4cd2ee835d20e004ad.jpg

Sent from my SM-A215U using Tapatalk

Share this post


Link to post
Share on other sites
Ok NPORA family, dusting this thread off to show that I DID try to research my issue before posting a new thread, but I still would like more current input from the pro's on here.

The pic is kind of hard to tell, but my passenger side has developed a slight negative camber. It occurred after an off road adventure awhile back.
Another issue worth noting is that when I took the front spacers off and drove it, the steering became increasingly erratic. Very much like the lower ball joint not being intact causing random pull. With the spacers on, this specific issue is not a concern.
Not sure why the spacers matter with this issue.
The steering has become more loose overall and has a slight "wiggle" in the steering wheel, hence why I'm doing a complete steering/suspension overhaul of original parts.

To the question at hand, based on your experience do you think I bent my strut when wheeling?
Are there any other things that I should consider before forking out for a new strut assembly.
And since I will already be doing a complete overhaul of the entire front suspension already. Are there any brands that would be better than others for replacement parts?

Thanks in advance for any insight provided!ac5c5d103d1cae4cd2ee835d20e004ad.jpg

Sent from my SM-A215U using Tapatalk



Do you have ironman springs?


Sent from my Pathfinder

Share this post


Link to post
Share on other sites

Lol, naw but I guess it may be helpful to add in my setup for additional insight.

Rancho 5000 strut w/ OME HD lift springs.

Sent from my SM-A215U using Tapatalk

Share this post


Link to post
Share on other sites
Lol, naw but I guess it may be helpful to add in my setup for additional insight.

Rancho 5000 strut w/ OME HD lift springs.

Sent from my SM-A215U using Tapatalk



Do you have cam bolts? Maybe it loosened and the cam moved?


Sent from my Pathfinder

Share this post


Link to post
Share on other sites

@03TroutFinder My bet would be a bent LCA. Same symptoms/cause as a buddy’s truck. Check the area of the arm where it leads into the rear stem mount. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...