Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Drifter2090

Members
  • Posts

    8
  • Joined

  • Last visited

Previous Fields

  • Your Pathfinder Info
    1993 Nissan Terrano TD27 RHD 74k Miles
  • Place of Residence
    Canada
  • Mechanical Skill Level
    Screwdriver Mechanic
  • Your Age
    16-21
  • What do you consider yourself?
    Do Not Go Off-Road
  • Model
    Terrano R3m
  • Year
    1993

Profile Information

  • Gender
    Male
  • Location
    Canada
  • Country
    Canada

Drifter2090's Achievements

NPORA Newbie

NPORA Newbie (1/5)

0

Reputation

  1. This is a clip of start-up and shutdown, we put some clear tubes here to see the fuel. Is this normal? https://www.dropbox.com/s/e691vn2krwc08k4/2014-07-17%2020.31.52.mp4
  2. When you say fuel pump are you talking about the primer pump? and also is it normal for the diesel to return back from the primer pump through the fuel line to the tank when you turn off the truck or should it just sit in the fuel lines??
  3. The problem still persists, I guess I will check the fuel pump again. any other suggestions?
  4. New fuel filter will be arriving soon I will update you guys after install.
  5. Thanks for help, I checked the fuel filter today and its seal was pretty destroyed so air was getting in, so I removed the filter and put a clear tube there and noticed that there were still air bubbles, is this the fuel pump then??
  6. Hey, I have a 93 TD27 RHD and when I start up the truck, I have to keep pumping the diesel pump until the engine is warm (even in the summer, but I have to pump less), If I do not pump it the engine the idle jumps around then the truck stalls. I have tried changing the whole diesal filter unit (including the hand pump) and the problem persists. Once the engine is warm It usually runs fine and doesn't stall. I heard maybe it could be the glow plugs? so I tried the multimeter test (set to 200) and all the plugs said 1.2, is this good or bad?. Anyone know what the problem is? Thanks
  7. Thanks for the reply, Is there a way to tell if its the fuel lines? and how could I get them cleaned?
  8. Hey, I have a 93 TD27 RHD and when I start up the truck, I have to pump the pedal until the engine is warm (even in the summer, but I have to pump less), If I do not pump it the engine the idle jumps around then the truck stalls. I have tried changing the whole diesal filter unit (including the hand pump) and the problem persists. Once the engine is warm It runs fine and doesnt stall. Anyone know what the problem is? Thanks

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...