Jump to content

madhakish

Members
  • Posts

    104
  • Joined

  • Last visited

Previous Fields

  • Your Pathfinder Info
    '93 XE 4x4
  • Place of Residence
    Minnesota
  • Mechanical Skill Level
    Screwdriver Mechanic
  • Your Age
    Choose
  • What do you consider yourself?
    Weekend Warrior
  • Model
    XE
  • Year
    1993

Profile Information

  • Gender
    Male
  • Location
    Minneapolis Minnesota
  • Country
    United States

Recent Profile Visitors

2,236 profile views

madhakish's Achievements

NPORA Veteran

NPORA Veteran (3/5)

4

Reputation

  1. Ok, so update since last post. Since I pulled and reseated all the relays she's not had a problem until today. Same as before, as soon as key hits position 2 power to the interior, light system and dash dies. Pulled all the relays and reseated them again, and pulled fuses 1 by 1 to inspect - found nothing only this time it was not resolved by reseating the relays.. So Im putting around with things and have the motor running and decide to gun it just to see - at about 3k rpm everything clicked on like a relay suddenly got the voltage it needed to close. So my question is this - which relay is responsible for all primary electrical power outside the engine/alternator/battery/ignition path? Not the main I gather but I don't have electrical schematics off hand.. Sent from my HTC6535LVW using Tapatalk
  2. Those be my wheels! And my paint color! Nice truck! Sent from my HTC6535LVW using Tapatalk
  3. 31x10.5x15 falken rocky mountains on d-window cragars.. Love em so far! Sent from my HTC6535LVW using Tapatalk
  4. After a relatively problem free 6 months or so, I've developed a new oddball. Occasionally (and i mean 1 in 10-50 tries) after turning the key to position one, all dash power fails. The clock goes out, blower, dash lights, stereo, head and tail lights all lose 100% power (stereo even resets to defaults). If I shut it off and turn it back on 20 times in a row it'll work fine, starts fine, runs fine. When the interior power does fail, it only appears to be lighting and interior electronics, the engine starts fine, runs fine, no misses, and I have ~13+ volts off the alt and at the battery.. I'm leaning towards a failing relay, as it only happens once in a while but is a complete power loss. Thoughts? Suggestions? I already went around and pulled all relays, put contact grease on them and made sure fuses were all ok. Can't reproduce as it's intermittent so only time will tell if that helped.
  5. '93 marked a change to certain things, and '94-95 brought the round dash, but I do t recall major differences mechanically. Sent from my HTC6535LVW using Tapatalk
  6. Starters are interchangeable, as is most everything else. Sent from my HTC6535LVW using Tapatalk
  7. I drove through Utah at 115f for a week crisscrossing the southern parks, a/c on full, needle pretty much stayed locked at about 3/4, maybe higher, never deviated, never boiled over. In winter the needle hovers at about 1/4, and below 0 I put cardboard in front of the rad to keep heat in. 250k miles, runs like a champion. If you are really concerned add some "water wetter" directly to your coolant (not the overflow). Sent from my HTC6535LVW using Tapatalk
  8. I see them but they're rarely if ever not rusting away. His was in pretty decent shape, rack, front and rear roof lights, nissan oem brush guard, 3" inch lift, and nismo stickers all over
  9. Alas, the mystery driver remains anonymous. Saw him again the other day, but was driving the BMW and I think he just thought I was weird for lookin so hard..
  10. Ahh, always good to find other locals on the board.
  11. Saw you in Robbinsdale MN - you ride here?
  12. I hate the &^%*ing eagles..
  13. Nnnnnnnnnnnnggggggg!!!!!! Want so hard.. Sent from my iPad using Tapatalk
  14. Hardbody+wiring upgrade is definitely wortwhile, looking forward to seeing it Sent from my iPad using Tapatalk
×
×
  • Create New...