Jump to content

Search the Community

Showing results for tags 'oil'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • NPORA Announcements
    • NPORA Announcements
  • General Topics
    • Forum Guidelines
    • New People Start Here!
    • General Forums
    • Truck of the Month
    • The Garage
    • Off-Topic
    • Solid Axle Swaps, Hardcore Custom Fab
  • Pathfinder Discussion By Model Year
    • 86.5-89 WD21 Pathfinders
    • 90-95 WD21 Pathfinders
    • 96-2004 R50 Pathfinders
    • 2005-2012 R51 Pathfinders
    • 2013-Present R52 Pathfinders
  • Classifieds
    • NPORA Vendor Section
    • Services
    • Parts For Sale
    • Free Parts
    • Parts Wanted
    • Vehicles For Sale
  • Regional Areas
    • United States
    • Canada
    • Central/South America
    • UK - England
    • European Nations
    • Russia
    • Japan/South Seas
    • Australia/New Zealand
  • Community Corner
    • Trail Run/Events

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Your Pathfinder Info


Place of Residence

Found 1 result

  1. Hi, I drive a 2005 Nissan Pathfinder SE and when I first bought it, it had a timing chain issue. After fixing the problem, I had very low oil pressure (this could have been a problem before I had bought it and I never noticed). I tried my go at waiting till it got better but then it got worst. There was other problems with the engine so finally we rebuilt the motor. At this point I'm 3 grand in, freshly machined motor inside of the car with a brand new expensive oil pump and after 120 miles of break in, the oil light comes back on. Everything about the engine was perfect and 3 mechanically trained people put it together. At this point I'm stuck not knowing what to do. Everything oil related was fixed, even the passage was and I just don't know what to do. The light only comes on when I am stuck at a stop light, and then goes away when I start driving. What can I do?

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...