Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Austinm20

Members
  • Posts

    4
  • Joined

  • Last visited

Previous Fields

  • Your Pathfinder Info
    98 r50 qx4
  • Place of Residence
    Ga
  • Mechanical Skill Level
    Screwdriver Mechanic
  • Your Age
    16-21
  • What do you consider yourself?
    Weekend Warrior
  • Model
    SE Offroad
  • Year
    1998

Profile Information

  • Location
    Kennesaw ga
  • Country
    United States

Austinm20's Achievements

NPORA Newbie

NPORA Newbie (1/5)

0

Reputation

  1. Okay sorry before hand I basically have no knowledge of motors at all. If my timing belt would have broken would I have seen it? Cuz I looked at all of my belts and they all seem to be there. Is it possible for it to have jumped timing somehow?
  2. I had the distributor cap off and had someone start it and it's not turning at all
  3. It's a 98 and I haven't been listening I'll listen for that when I try to start it up next.
  4. Okay so from the beginning when I originally bought the truck (around 2 and a half months) it was fine. Saw a slow leak of oil and changed the oil and filter(it wasn't screwed in all the way or something) and I was driving it down the highway doing probably 70 and it backfired and shut off completely. Now every time I start it, it tries to turn over but won't fire over completely I have no idea what to do as I have never had a problem with something just not starting and don't know where to look

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...