Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Not starting after cleaning throttle body


Recommended Posts

So like an idiot I didn't remove the battery while cleaning the throttle body and now my gas pedal goes all the way down and doesn't control the throttle body. I used the correct cleaner and lifted the butterfly valve. The engine turns over but doesn't start at all. I've tried doing the 10 seconds on, 2 seconds off throttle body relearn but that isn't doing anything. Did I break the sensor?

Link to comment
Share on other sites

Okay so I believe the previous owner had a kill switch to the gas pump relay because I'm not getting any voltage to the pump. However I found this red button switch that was placed next to instrument cluster dimmer but can't find it linked to anything.

Edited by Beneficial
Typo
Link to comment
Share on other sites

I have heard of the drive-by-wire getting its panties bunched when there's a sudden change in air flow vs throttle angle, and requiring a relearn procedure (should also be in the '03 service manual) to convince it that the sky isn't falling, even if the throttle body itself isn't damaged. IIRC someone on here couldn't get the relearn to take and had to have a dealer talk it down. I haven't heard of that stopping the fuel pump, though. When are you checking for power? Usually fuel pumps run when the key is turned on, briefly, but then stop until the computer sees that the engine is turning. Can you hear the pump run for a few seconds if you turn the key to the run position without trying to start it? Unlikely that the PO's kill switch happened to fail at the same time you cleaned the throttle body.

 

Could also be that it won't start because the throttle body is fully closed. AFAIK the drive-by-wire rigs don't have separate idle control, so if the throttle body is damaged, and it's stuck fully closed, that could be why it's not lighting off. 

Any codes?

Link to comment
Share on other sites

I will try the relearn procedure again but it was really frustrating trying to figure it out to see if it was even working. The gas pedal still feels with no resistance. The big red button I don't know if it was just coincedence but I can't imagine it was anything other than a killswitch. My OBDII port no longer powers my scanner for more than a couple seconds. So I can no longer check for codes. Even after charging my battery up again with a trickle charger and confirming a 12.5V from the battery. I don't believe I can hear the pump but I will check again tomorrow. 

 

I've tried to start the car while manually holding the throttle body open while someone else would crank the engine. 

 

I sprayed a little bit of starter fluid into the throttle body and it started for a split second then died. 

 

I need to go through each terminal that can possibly be linked to the fuel pump and confirm that this isn't the fuel pump.

 

I'm going to try the relearn process 20 times and see if this works

Link to comment
Share on other sites

Update!

 

It was the ENG CONT fuse. My OBD scanner wasn't working when I connected it and set the car to ignition. I found that odd and saw that there was the correct battery voltage going into the OBD port. So somewhere the ecu was not talking to the car and I decided to check fuses for continuity. Now it starts up no problem!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...