Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Parts availability is really beginning to suck!!


Recommended Posts

Just a quick question,

 

I am in search of a new wiper switch PN 25260-03G01. It wasn't used on a Japanese model and not available through Amayama Trading Co. Did a search for that alone, and it appears to be available at a place in Alberta, Canada called Nissan Parts Online https://www.nissanparts.online/. They seem to have a lot of parts available where they're unobtainium anywhere else.

 

Has anyone dealt with these people. The website seems secure, I just don't want to throw some money at a hack and be out of pocket.

 

Thanks

Geoff

 

 

Link to comment
Share on other sites

Welp, I ordered it and paid through PayPal. Shipping was a bit much, but if that's the only place that I can get it from, that's the only place I can get it from... Overall cost was $150 CAD. With the exchange rate, that should come up to about $120.... We shall see how this pans out.

Link to comment
Share on other sites

I ordered the rear lift gate rubber stops through them (not the canadian site though.) Shipping was fast. Items were correct. Who knows how they are after lockdowns and such, but they were great a couple years ago. 

Link to comment
Share on other sites

I just got notification that they weren't able to ship the part because they didn't actually have it... go figure.... :ar15:

  • Sad 1
Link to comment
Share on other sites

I can't find a photo for that part #, I'm guessing it's the one with the twist knob at the end for the wiper frequency? I've got a spare wiper switch, but it's off a base model Hardbody, so it doesn't have the intermittent function. I haven't checked whether the plug is the same. (Edit: just checked, yep, same plug. Plugged it into my '93, works fine. The intermittent function is a separate two-pin plug.)

 

Gonna have to be more careful with mine. I didn't realize they were unobtanium.

Edited by Slartibartfast
  • Like 1
Link to comment
Share on other sites

Ya, mine has been flaky for a couple of years, now it doesn't work at all in the intermittent position (When it's just sitting there). I thought it was the module under the hood, but this is clearly the switch.

 

When I merely tap it, it works for just the one wipe.... and every single time I tap it.  If I could get a new one, I would... or... at least I tried... Guess I'll have to try to take it apart and see if I can do anything to make it work... Or find something on eBay or a salvage yard... or just say F-it and let it fall apart like the 30yo bitch that she is... She is a discouraging one... maybe I'll name her "Amanda"?

Link to comment
Share on other sites

Sounds like the switch controlled by moving the stalk is okay, but you've got an open in the time delay circuit. I would hook an ohmmeter to the two-pin plug from the switch and see if you've got a resistance that changes when you try to adjust the interval. If not, I would guess broken wire or bad pot, or maybe some stupid fiddly bit of plastic connecting the knob to the pot. The question then is whether the stalk will come apart in a civilized fashion or whether the old plastic is gonna do old plastic things and leave you worse off than when you started.

 

If the resistance checks out, I would take a second look at the wiper amp. EL-71 in the '90 manual has a check for it (not sure what exactly it's checking, though) and EL-68 shows the circuit diagram. If you've got resistance at the switch, and the same resistance at the plug for the amp (looks like you'd test from red/blue stripe to ground), I'd have a poke at the amp.

 

Edit: found this. Same symptom, bad amp.

Edited by Slartibartfast
Link to comment
Share on other sites

  • 2 weeks later...
On 4/23/2022 at 11:37 PM, Slartibartfast said:

Sounds like the switch controlled by moving the stalk is okay, but you've got an open in the time delay circuit. I would hook an ohmmeter to the two-pin plug from the switch and see if you've got a resistance that changes when you try to adjust the interval. If not, I would guess broken wire or bad pot, or maybe some stupid fiddly bit of plastic connecting the knob to the pot. The question then is whether the stalk will come apart in a civilized fashion or whether the old plastic is gonna do old plastic things and leave you worse off than when you started.

 

If the resistance checks out, I would take a second look at the wiper amp. EL-71 in the '90 manual has a check for it (not sure what exactly it's checking, though) and EL-68 shows the circuit diagram. If you've got resistance at the switch, and the same resistance at the plug for the amp (looks like you'd test from red/blue stripe to ground), I'd have a poke at the amp.

 

Edit: found this. Same symptom, bad amp.

I really don't think it's the amp. If I put it in the intermittent position, and I gently tap it, it works once and every single time I tap it. My money is on that it's a weak spring or dirty contact internal to the switch. Again, If I could buy new, I would. I would also buy a new column crash pad since mine is being held in place by gravity. Someone over the years, snapped the screw posts that hold it together.

 

I have had a white fungus grow inside this thing when it sits for an extended period of time in the moist winters we have here, and I think that may have fouled up the contacts. This fungus has appeared three time since I have owned it. Once when I was active duty and out to sea over the winter, and the past 2 winters when I developed the head gasket leak and most recently the rear brakes/axle @!*% themselves. What's really intriguing is that the individual dash lights would come on and off randomly after I got the heads fixed. It took a while, but they finally all stayed on after a week or so of driving it. 

Link to comment
Share on other sites

On 4/25/2022 at 1:15 PM, SpecialWarr said:

worst case, I can pull the one out of the 1990 and ship it to you.

Thanks, I might have to hit you up on that if it proves to be terminal. It might take me a while to get there and figure out if I really need a replacement or not, as it's not exactly anywhere on my priority list.

Link to comment
Share on other sites

The column covers always do that. Weak brittle screw posts. Probably doesn't help that it's in a prime spot to get smacked by knees. Mine wasn't worth putting back on, so I made a metal one instead. It ain't pretty, but it's stout.

 

Can't help with the fungus, that's nasty. Hopefully there isn't a great gob of that inside the switch.

  • Like 1
Link to comment
Share on other sites

@Slartibartfast I had a 95' D21 years ago that I was fanatical about turning the screws to the left until they clicked and then screwed them back in place. 12 years ago, that thing was in pristine condition. A lot, I would wager most, of the people do not know how to preserve plastic screw receptacles, as well as sheet metal screws. It's been a while, but the kickplates are not at all easy to take out without F-ing the screws up too. Not to be racist, but you must be ginger taking those out ?

 

I'm not tall. Some would consider calling me under-average height. I have never hit my knee(s) on the column crash pad unless the seat was pushed all the way up for whatever random reason. All of the parts are in that I can get for the rear end and I'll follow up with any interesting results. Should be this weekend... ish... maybe... I have to get my motorcycle to get back on the road as well now that the weather is getting nicer.... and gas is still espensive... 

Link to comment
Share on other sites

I've never taken one of these clamshells off where the plastic wasn't either gone or well on its way, though to be fair that's a sample size of four.

 

And, yeah, those plastic trim screws are the worst. After buggering a few of them I realized you've gotta use a flat-blade screwdriver with as little down force as possible. If it's slipping, hook a fingernail under the head as soon as it lifts. An early HB I scavenged had regular metal screws into plastic inserts, like how the front corner lamps mount, not sure why they moved away from that.

 

Good luck with the bearings. If you still want to borrow that socket, I think the pass opened this week.

 

 

Link to comment
Share on other sites

16 hours ago, Slartibartfast said:

I've never taken one of these clamshells off where the plastic wasn't either gone or well on its way, though to be fair that's a sample size of four.

 

And, yeah, those plastic trim screws are the worst. After buggering a few of them I realized you've gotta use a flat-blade screwdriver with as little down force as possible. If it's slipping, hook a fingernail under the head as soon as it lifts. An early HB I scavenged had regular metal screws into plastic inserts, like how the front corner lamps mount, not sure why they moved away from that.

 

Good luck with the bearings. If you still want to borrow that socket, I think the pass opened this week.

 

 

I don't think they were metal screws from the factory, someone else probably got fed up and put them in there lol.

Link to comment
Share on other sites

  • 4 weeks later...

I agree with @adamzan  most reliable and probably my most trustworthy vehicle.... not the smoothest, fastest or most comfortable but as reliable as my Estwing hammer. Same reason I bought the '01 Xterra although I need to keep working on the X to get it into trustworthy status..... we close though!

Link to comment
Share on other sites

On 6/7/2022 at 9:32 PM, adamzan said:

Idk, mine has probably been one of the most reliable vehicle's I've owned.

i just mean in terms of finding parts, ya know, the context of this thread xD

Link to comment
Share on other sites

Well that's always been the case lol. At least over here. Now that I have friends that work at the parts store @!*% is actually in stock. I remember even when these rigs were newer brake pads and @!*% were always special order :( 

Link to comment
Share on other sites

I'm ok with having to order things. It's the fact that some of the replacement parts are not available period. If someone were to make more aftermarket parts... that would be great... But I am seeing fewer and fewer of these critters on the road nowadays anyway... I'm pretty sure these things don't even create any kind of spike in the "collector" world, so there is little to no market for it.

Link to comment
Share on other sites

I keep looking at the hockey tape on my arm rest and thinking there's gotta be enough of us left to make reproducing those worthwhile. I've even had "how hard could it be" thoughts involving silicone molds and foam in a can. Then I think about how long that would take, and what I'd be willing to pay for an armrest, and remember why mine's got hockey tape on it.


I've been surprised at what's available for more popular platforms, though of course not all of the repop parts actually fit. That said, availability for these could be a whole lot worse. Try finding parts for a '59 Triumph 10 wagon.

Reminds me, someone on an IH forum I'm on found a substitute for the hard-to-find rear window motor for the Scout II. His donor was a Studebaker Avanti. I told him that's like a cooking show saying, if you can't find unicorn steak, jackalope will do.

Link to comment
Share on other sites

If I could get a new armrest for mine I would 100% lay out the cash for it. It bothers me to no end lol. Trying to keep mine as mint as possible.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...