Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Exhaust


Teesetz
 Share

Recommended Posts

Finally got rid of the hideous stock exhaust and tip. 2.5 cat back with the shortest magna flow I could do. Unfortunately no off road adventure yet. Mostly family errands. Can’t wait for the summer 103a3146373e2f31c468cc70c7fb1ea6.jpg

4d5b50cd8e0676918c57d1a28ccd19f3.jpg

9ffbf654290c4b8ba1094a325904b342.jpg

be3c910f9db374a5707771be5ea5d738.jpg

Link to comment
Share on other sites

Can’t put a video up till I figure out the intermittent idle surge and stall at idle. I think I’ve found the culprit, got a connector on the way. Hoping it’s not the iac ad4e5d92dd6e3e0ea6715d7aafc4f2d1.jpg
b8dffdc26062c5b7fcf410378fecf6ad.jpg

Link to comment
Share on other sites

The IAC is super easy to clean after you get it off. The only real PITA part is getting your right hand under the rear of the intake to remove the retainer clip, and plugging the new one back in...

Link to comment
Share on other sites

Thanks for the info! I took off the MAF and housing and gave it a good cleaning. I also switched back to a wix filter because I’d heard horror stories of the knandn getting oil on the maf, crap sticking to it, and sending fooey voltage. Also cleaned about 2 shop towels worth of carbon build up from the throttle body housing. Running like a top now.

Link to comment
Share on other sites

Been running a K&N in mine for 21 years. Still have the same MAF sensor it had when I bought my truck Feb 99. If the filter is oiled properly, there is no problems. One of those situations of less is more. When the filter is over oiled like many people do is when you get problems of oil on the MAF sensor. 

Actually on my second K&N. The first one died a terrible death protecting my engine when the mud hole got too deep and the airbox filled with mud. Clogged the filter and the suction unfolded and mangled the mesh. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...