Jump to content

Due to a hardware failure on the hosts systems, all posts and messages created between May 26th and Jan 13th have been lost. Additionally, if you joined the NPORA Forums community during that time, you'll need to re-register. -NPORA Mod Team *Updated: 05/19/2022 12:15AM PST

Clutch issues


chen2761
 Share

Recommended Posts

I have a 1988 Pathfinder, 4x4, two door.  The clutch pedal was not returning and sticking so I replaced both the master cylinder and slave cylinder and bleed the system.  Pedal felt great and shifted fine for a day and 1/2.  On my way home at a stop light, shift to 1st and take off fine, shift to 2nd fine then 3rd and the engine revs up and nothing catches, like it is in neutral.  I try all gears, same thing like it stuck in neutral.  I can shift into any gear easily but nothing catching engine on or off, just feels like it stuck in neutral.  Can a clutch go bad the fast? or could it be something else keeping it from engaging the gears?

Link to comment
Share on other sites

Could be that the clutch let go, or the release bearing could be stuck. Does the pedal still feel normal, or does it feel like there is nothing there? If it still has normal or close to normal feel, then it is likely the clutch has died. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...