Jump to content
Sign in to follow this  
k9sar

R51 oil pressure reading?

Recommended Posts

Noticed yesterday that my oil pressure reads maxed all the time (unless the truck is turned off).  Even with the key just turned to the on position without the engine running, it flips to maximum.  I know this isn't normal but my question is, for an R51, does the pressure read completely low or completely high when the key is first turned on?  Can someone take notice and let me know?  Deciding whether to chase a bad sensor or bad electrical.

Share this post


Link to post
Share on other sites

You have a dead short to ground in your oil pressure circuit. Most likely in the sending unit. Unplug the wire from the sensor, and if the gauge drips back to zero, then the problem is the sender. If not, then you will have to check the wire for a short to ground.

  • Like 1

Share this post


Link to post
Share on other sites

yep. dead sensor.  RockAuto here I come.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...