Jump to content
Sign in to follow this  
vf24renegade

Engine Stumbling Caramel Smell

Recommended Posts

Okay, 95 Pathfinder XE. 406,000 miles, changed timing belt ,front seal and rotor arm a few months ago.

Cool mornings, runs fine. On hot afternoons, after about 20 miles, the engine will occasionally stumble. It will jerk and a noticeable RPM dip when it does it. 

usual driving speed is 55 mph. After stumbling once or twice, it will pick up and run fine for a few more minutes. Then after shutting down, as in going into the parts store, it will be difficult to start and idle rough. Caramel burning smell. Then when driving, it stumbles continuously and can go about 20 mph. after a few minutes, the engine speed gets up enough to shift gears and can go 35 to 40 mph and stumbling decreases. after a few minutes, can cruise at 45 to 55 with even less stumbling. After a few more minutes, back to 55 and no or very little stumbling. 

 

Observations:

Doesn't matter whether AC is off or on for this problem to occur.

Only occurs when the outside temperature is high (85 or more).

The temp. gauge shows normal (1/2 scale or less).

There is coolant in the reservoir.

It seems as though the engine or compartment is getting hot and is cooiling down as air is moving around it. But as noted above, the temp gauge is normal and it does vary, so not stuck.

There is a smell from the front of the car which resembles caramel or a distillery like something sweet is burning. Doesn't smell like hot coolant or oil or burning wire insulation.

 

Actions taken:

Replace fuel filter.

Checked EGR valve for movement.

 

Any ideas or similar experiences? Thanks.

 

 

Share this post


Link to post
Share on other sites

Update: Additional observation: It appears to happen under situations calling for more torque or power.

Share this post


Link to post
Share on other sites

If you have access to a timing light or in line spark tester, you might want to see if the ignition system is firing normally or if it is dropping spark when it is acting up. I had a distributor give me problems in my old 200sx when it got hot. You might be having a similar problem or the coil could be breaking down. 

 

Possible injectors could be failing also.  Could get a few cans of canned air for blowing out things like computers and with the can upside down, spray suspect components to cool them and see if will improve. You did mention that it will idle poorly when it is acting up, the tests I have suggested are not recommended when driving. 

Share this post


Link to post
Share on other sites

Sounds like what my 96 3.3L was doing before the distributor module went out. Started out just once in a while and progressively got worse and worse and one day it just quit and the engine wouldn't start again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Welcome to NPORA Forums

 

Please REGISTER to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...