Jump to content

Z24s with carb and point ignition , help with ignition ground !!

Recommended Posts

 HI !!!

I do not own a pathfinder, I have a king cab, 4x4, d21 with what i believe has the same engine as some of the older pathfinders.

(z24s carburated, point ignition, 4 plugs, 1 ignition coil and external resistor and single points).

There is only 2 wires on the distributor , one is blue and is going to the ignition coil negative side , if disconnected the engine stops.

The other on is Black with a yellow stripe on it and it goes in to the main harness., if disconnected nothing happens .

The black/yellow wire is supposed to be for the distributor/ignition ground ,,, !!/??

I was convinced that the distributor had ground from the engine block and that was enough for the ignition to work properly.

The problem is that i keep burning my points and condenser , they may last one week at most and my ignition timing keeps fluctuate.



Share this post

Link to post
Share on other sites

I think even the 4-banger trucks had electronic ignition here. I'm not familiar with Nissan's points dizzy wiring, but I'd be curious to see how the ballast resistor is connected. My understanding is that the points and coil get full battery voltage when the starter is engaged, but once it's running, power is re-routed through the ballast resistor to reduce the voltage to the coil (reducing load on the points and making the coil run cooler). If the coil gets full battery voltage all the time, you burn out the points or overheat the coil. Check the voltage from your coil + terminal to ground with the key on.


I'm not sure why the dizzy would have an extra ground wire. Maybe Nissan didn't trust the connection between the head the dizzy for ground, and worried current would go through the bearings? Or needed a convenient engine ground for something else?


The only points vehicle I have much experience with is the family snowplow ('63 IH Scout). They worked alright, but we ended up swapping them out for a Pertronix solid-state so we'd have one less thing to check when it wouldn't run right.


Share this post

Link to post
Share on other sites

I am convinced I have a ground issue , I have checked everything else.

Ignition coil is ok ,new , (1.4-1.7ohm primary) , Coil resistor ok , (1.6ohm).

Points and condenser new , (condenser 0.22 microfarad).

I tested one of the sparkplugs for spark , touching the point where the ground wire goes to engine from battery....very weak spark !!

However....!!!!.....esterday i happen to touch the high tension cable from the coil to dizzy....my hand touched the chassis at the same time...i felt a weak current on my hand.

Immediately I thought there was something wrong with the cable so I replaced it with a new one ... but the same happen with the new one ... so i tested another new one ... the same ... i felt the current.

I might try to replace the ground cable from the battery to the engine...!!

Every thing else on the car works fine....(except for the fuel pump relay) , start motor ok .. lights ok , 

Edited by Chrisco

Share this post

Link to post
Share on other sites

Not sure if this will work, but let try and get B's attention here as he was a 720 guy before Pathfinders.


Calling @Precise1 for some advice!!!

Share this post

Link to post
Share on other sites

Thank you for all the help ... specialist assistance would be appreciated !!!!

Yesterday i replaced all ground cables from battery to engine .. and engine to chassis....(basically only two wires)...I also replaced the condenser and points,,new ones....lets se how long they will last...(the spark is still weak)

Today i try to replace the fuel pump relay...maybe that affects the ignition somehow...(https://axleaddict.com/auto-repair/The-Datsun-and-Nissan-Pickup-Fuel-Pump-Relay-What-the-Haynes-Automotive-Repair-Manual-Wont-Tell-You)...a longshot , i know...

last year we could not get a nissan almera to start ..... after 10 days of diagnostics we were ready to give up ...nothing worked.

By a coincidence, I saw that one stop light was out of order , i replaced it and the stupid engine started...i disconnected the light again and the engine would not start..reconnected the light and the engine started....!!!.....mysterious nissan !!!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Welcome to NPORA Forums


Please REGISTER to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.