Jump to content

Recommended Posts

Hello everyone!

 

My name is Anthony Croyle. I inherited my mother's 1992 Nissan Pathfinder SE back in May, and I decided to start dumping money into it to get it up and running. After installing a new battery, she was running like a charm. I then installed a 20" Nilight Light Bar, PA system, CB radio, and a warning beacon. A few days ago, I put in a new air filter, a fresh set of spark plugs, an ignition coil, new ignition wires, a rotor, and a new distributor cap since the entire ignition system was having issues. Notable issues I am still having include a bad ground connection (resulting in the lights occasionally flickering, the gas and temp gauges not working, and a radio that won't stop changing frequencies randomly), a leaking exhaust system, and a couple squeaky shocks. If I said any info that may be misleading, feel free to correct me! I can't wait to get my Pathfinder up to 100%. 😎

 

Photo of my Pathfinder as of June 18th

  • Like 3

Share this post


Link to post
Share on other sites

Welcome!  That's a great year Pathy (except for the missing cupholders, lol).   Lot's of great people here!  Cheers

  • Like 1

Share this post


Link to post
Share on other sites

Welcome to NPORA WAVEY

 

I suggest you read through this thread, it should address at least a couple of your issues :Aok:

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

:welcome:

Lets see some pics  :aok: and keep us up-to-date.

Lot of info here, if not everything there is to know.

Share this post


Link to post
Share on other sites

Welcome !

Share this post


Link to post
Share on other sites

Hi everyone!

 

It's been a while, and I've repaired quite a few of issues with my Pathfinder. First of all, there were no bad grounds from what I could diagnose. I did fix a few potential wiring problems, and prevented more from happening in the future. Replacing the radio with a much newer one out of my previous vehicle fixed the issue with my radio changing frequencies. The gas and temp gauges are still broken, so I'll likely stop by a Pick-and-Pull to pick up an instrument cluster. The flickering running lights stopped when I removed a wire that was shorting on the chassis. I've done a few improvements to the exhaust to reduce, but not completely stop the air leaks (replacing manifold gaskets, patching holes in piping). In order for me to replace the gaskets, I had to cut the EGR tubing and the Y-pipe to pull the headers off (came with an aftermarket exhaust). There are still leaks where those are, so I'm using exhaust wraps and clamps until I can get access to a welder. Lastly, the squeaking shocks have quieted down ever since I used brake cleaner on them. Other notable changes include a new brake master cylinder, new brake line to the front passenger side caliper, a new caliper bracket and guide pin set for the same caliper, new washer fluid pumps, and new wipers to go with that.

 

Now for some other changes since I've last posted:

 

I moved the light bar to the bull bar, and took off the KC lights. I also installed two new flood lights (10800 lumens each) below the front bumper. The rear KC lights were switched out with new 18-watt flood lights. I installed a reverse alarm with a switch to turn it off when necessary as well as a backup camera. Full exterior LED conversion. Instrument cluster LED conversion. Four custom LED side markers installed in the fender flares. Front license plate light. I repaired the alarm system, but still can't get my power locks to work (relay clicks in the back, so possible actuator problem?) Then there's a rear dual-row LED strip with brake lights (hard-wired strobe module installed later on), reverse lights, and blinkers hard-wired into the lighting circuit. The coolest new toy would have to be the exterior underglow! Did I mention there's interior underglow too?

 

"The Pathfinder Project" Album

Edited by MiltonWATech99
Added Google Photos link
  • Like 1

Share this post


Link to post
Share on other sites

:welcome:

Looks nice, keep us up to date :aok:

Share this post


Link to post
Share on other sites

Welcome! Where are you located, PNW?

Share this post


Link to post
Share on other sites
On 11/27/2018 at 8:10 AM, RainGoat said:

Welcome! Where are you located, PNW?

Yes. I live in Milton, Washington (south of Seattle and east of Tacoma).

  • Like 1

Share this post


Link to post
Share on other sites

Welcome.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Welcome to NPORA Forums

 

Please REGISTER to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×