Jump to content
Sign in to follow this  
cdhicks99

Transmission issues again

Recommended Posts

I have just purchased another WD21 (I will give details on my steal later).

Needless to say it has AT problems, I am looking for rebuild kits.

However I cannot remember nor find the tranny code. (eg. RE4R01A, RE4R03A, RG4R01A, JR403E etc)

Does anyone know which is which?

Share this post


Link to post
Share on other sites
RE4R01A is the tranny code

Thats what I thought by process of elimination, but I needed confirmation...Thanks a ton.

Share this post


Link to post
Share on other sites

Have a look @ my members rides thread for links to the trans place I dealt with....Just rebuilt my trans

Also you'll find the extra parts #'s of some parts the kit was missing.

Check out the "How to" section as well for my write up on installing the shift kit :beer:

 

Good luck with the rebuild....May the force be with you :lol:

Share this post


Link to post
Share on other sites

Has anyone needed to replace the pump?

If so where did you find it?

Share this post


Link to post
Share on other sites

The pump is behind the torque converter :aok: Removal requires taking the bell housing off :D

Share this post


Link to post
Share on other sites

lol, thanks.

Can I buy one though?

Share this post


Link to post
Share on other sites
lol, thanks.

Can I buy one though?

I'm guessing through a dealer....Ask Derek or the other guy who works @ a dealership who sells parts to us :aok:

 

Can't find one on other sites, not even the one I bought my kit from :shrug:

Share this post


Link to post
Share on other sites

OK. I received my master kit and shift kit Thurs. last night me and a buddy tore it down, got it cleaned, and got the reverse pack back together.

 

*Anyone attempting a rebuild should keep in mind, you will need a press for the direct and forward clutch packs*

 

I am hoping to have the trans together tonight and the valve body should get done tomorrow.

I will not be dropping the existing tranny until my Headers get here next week. As much as I wish I could drive it next week it looks like next weekend at least.

 

**Big props to TerranoNZ, who has been a huge help. Thanks again man!**

Share this post


Link to post
Share on other sites
OK. I received my master kit and shift kit Thurs. last night me and a buddy tore it down, got it cleaned, and got the reverse pack back together.

 

*Anyone attempting a rebuild should keep in mind, you will need a press for the direct and forward clutch packs*

 

I am hoping to have the trans together tonight and the valve body should get done tomorrow.

I will not be dropping the existing tranny until my Headers get here next week. As much as I wish I could drive it next week it looks like next weekend at least.

 

**Big props to TerranoNZ, who has been a huge help. Thanks again man!**

 

I didn't have a press, just made something ugly that worked :D

 

DSC01748.jpg

 

DSC01749.jpg

 

Would of been easier to have the correct tool, but they got the job done.

 

Don't forget to hook up the check valve to the shifter when putting the valve body back on.

 

:beer:

Share this post


Link to post
Share on other sites

NZ, in the shift kit it shows a plunger that I'm supposed to flatten dimples on,

where exactly is that plunger located?

It doesn't give any diagrams regarding where to get it, only how to fix it...

Share this post


Link to post
Share on other sites

Is that the orifice plug? Mine didn't have the plug, so I didn't need to do it.

 

DSC01753.jpg

Share this post


Link to post
Share on other sites

No, I will have to take pics tomorrow I guess.

Share this post


Link to post
Share on other sites

I have yet another problem. I can't get the aluminum plugs out of the valve body that I am supposed to replace with new steel ones.

Any ideas?

If so msg me plz so it will come to my phone.

Share this post


Link to post
Share on other sites

OK, the tranny is done with the exception of the harness that goes into the side. Upon trying to remove it from two different trannys, the little tits that hold it in have broke on both (high heat damage I believe). Anyone else had this problem? Any suggestions for a leak-free fix?

Share this post


Link to post
Share on other sites

As for an update to the chaos that began as a simple tranny rebuild and header install. (Two weekends I told my wife)

 

As you can tell from the previous posts the rebuild was not exactly cut-and-dry. I ended up having to use the valve body from my 94 as the other two valve bodies had stuck valves that could not not be moved at all.

Luckily (or unluckily) last Fri. the 94 died on my wife with an exploded front pump, providing the afor mentioned valve body.

The 94 also had a brand-new alternator (1 day old) so that will be going into the 95.

While under the 95 I noticed the valve covers have been leaking terribly which saturated the starter, again luckily the 94 has a fairly new starter.

Of course the right rear manifold stud was broken on the 95. While removing the manifolds two more snapped on the right and two on left. Removing these was too much to handle in the vehicle, so the engine has now been pulled which should make things a little easier.

Needless to say my two weekend project has been extended with no set date to finally get to drive my latest "great deal".

 

Side notes: The 94 will finally get what it's been waiting years for....custom frame, SB Chevy/350T/Atlas(or 203/205), D44/Ford 9".

 

I will NEVER mess with another Nissan AT, if the 95's tranny goes again it will get a MT!

Share this post


Link to post
Share on other sites

Well tranny and engine are in.

Unfortunatly it wont shift from 2-3....

and the saga continues....

Share this post


Link to post
Share on other sites

Crap!! Have you run the AT diagnostics??

 

B

Share this post


Link to post
Share on other sites

Yeah, nothing came up on the self-check.

Reading the FSM it looks like the valve body AGAIN!

I just ordered a new one from W.I.T.

I am going to attempt to change it with the tranny still in the truck :blink:

Share this post


Link to post
Share on other sites

B if you were closer I'd hit you up for your MT.....cause this AT sh** sucks.

 

 

 

but I still love my pathy!

Share this post


Link to post
Share on other sites

Damn again, best of luck with that!!

 

Ok, you are scaring me again!! Now you have me wanting to swap or keep all the parts JIC!!

 

B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...