Jump to content
Sign in to follow this  
Tungsten

Slight Oil Leak

Recommended Posts

After driving my truck for a few miles, I have noticed a small oil leak coming from under the pan area. I don't know what it is yet but it looks like engine oil. Is this a common problem somewhere? Any thoughts before I go to the shop?

Share this post


Link to post
Share on other sites

well this morning i found out that i am loosing brake fluid and the rear right disk is slightly squealing when the brake pedal is half way down

 

could it be the brake master cylinder????

Share this post


Link to post
Share on other sites

to check to see if its the master cylinder look at the base of the MC right at the brake booster and if there is fluid coming out right there (location of the weep hole) then yes the MC is bad. check the rear pads for wear but Idont think low fluid would make them squeak

 

as for the initial leak mentioned try and follow the trail of fluid to the original location...it may be beneficial to clean it all off and look for fresh oil. Some of the common leaks are the valve cover gaskets. If not then it could be the pan itself, oil pres sending unit, RMS or the FMS

Share this post


Link to post
Share on other sites

RMS? FMS? whats that? :blond:

 

and the trail goes to the front diff :S

that can't be it...

Share this post


Link to post
Share on other sites

Oil filter on tight? I see that alot(not on Pathfinders specificly, just in general)

Share this post


Link to post
Share on other sites
RMS? FMS? whats that? :blond:

 

and the trail goes to the front diff :S

that can't be it...

 

rear main seal, front main seal

Share this post


Link to post
Share on other sites

Upon a closer examination, the oil leak was coming from the bottom of the transmission where it is connected to the engine. I wiped the area with a rag to check it out and it appears that it could be coming from the drain plug. Could it be the drain plug? After cleaning the area out, starting the engine and driving in a circle, there is no more leak. If it comes back I am suspecting that when the oil was changed the drain plug was not torqued correctly. The manual specifies the tightening torque to be 22 to 29 ft-lb. on the drain plug.

 

As for brakes, nothing is leaking right now but when I topped off the container to the max level with DOT 3 brake fluid the BRAKE light on the dashboard came on (my handbrake is down). I will do some more observations on that but I am sure it could be the Master Cylinder. The MC was replaced around 2 years ago and I am suspecting that the replacement part could be crap. I could not find any weep holes on there but there is a probe inserted below the fluid container. Could that be the weep hole probe or something?

Share this post


Link to post
Share on other sites

It may be torqued correctly, but the washer/seal is shot. Make sure to replace it next oil change (any automotive store will have them).

 

B

Share this post


Link to post
Share on other sites

Thanks B

 

I could not find any weep holes on there but there is a probe inserted below the fluid container. Could that be the weep hole probe or something?

 

This is actually a reed switch, I bet the float is stuck, will give a few whacks on the container...

Share this post


Link to post
Share on other sites

You are welcome.

 

Check the wire connection for the MC also...

 

B

Share this post


Link to post
Share on other sites

well taking the reed switch out and cleaning it made the light go away lol

Share this post


Link to post
Share on other sites

arghf the crossmember is still getting soaked in oil

someone plz tell me its not the oil pump seal like on doctorbills

i had the timing belt done and the cam seals replaced already

 

:(

 

also, new master cyl for brakes and new drain plug

 

i swear its turning into a ford

i wanna go blow something up now

Edited by Tungsten

Share this post


Link to post
Share on other sites

it must be a boy... its just markin its spot... :aok:

Share this post


Link to post
Share on other sites

my master cylinder used to leak. then it sat for a few years. and for some reason it doesnt anymore...lol

Share this post


Link to post
Share on other sites

i'm thinking oil pan gasket

it only leaks when i'm standing still, there is no oil trail behind me or anything like that

the oil pan and the crossmember is wet with oil i don't see anything else

will check the bottom of my timing cover soon just to be sure (it better not be the oil pump gasket :headwall: )

Share this post


Link to post
Share on other sites
i'm thinking oil pan gasket

it only leaks when i'm standing still, there is no oil trail behind me or anything like that

the oil pan and the crossmember is wet with oil i don't see anything else

will check the bottom of my timing cover soon just to be sure (it better not be the oil pump gasket :headwall: )

 

I had a leak from the oil pan gasket. I thought it was the rms, but my guess was the rubber gasket got pinched when the 2nd clutch was installed.

Edited by jgt

Share this post


Link to post
Share on other sites
i'm thinking oil pan gasket

it only leaks when i'm standing still, there is no oil trail behind me or anything like that

the oil pan and the crossmember is wet with oil i don't see anything else

will check the bottom of my timing cover soon just to be sure (it better not be the oil pump gasket :headwall: )

Have you tried tightening the oil pan bolts? The torque is light (something like 8-12 ft/lbs or something), I'l have to look it up for you. My auto tranny pan was weeping when I bought it, spent 10 minutes with a 1/4" drive 10mm socket and problem solved.

 

B

Share this post


Link to post
Share on other sites

If the leak appears to be coming from the bottom of the tranny on the engine side I would say it's a rear main seal. That has been a consistent oil weeper on all of the Nissan D21/WD21s that I have replaced clutches on. It can probably wait until you need a clutch unless it's leaking profusely. The leak can shorten the life of the clutch though.

Share this post


Link to post
Share on other sites

Looks like it is the RMS and I have an auto so there is no clutch.

Share this post


Link to post
Share on other sites

Got a quote at the shop today for doing the RMS, came to about $700.

Share this post


Link to post
Share on other sites

Sounds about right. It'll cost you the price of the seal+inconvenience if you can/do it yourself... :shrug:

 

B

Share this post


Link to post
Share on other sites

Transmission? We don't need a transmission! P...

 

image005jb.jpg

 

image009i.jpg

 

image008hc.jpg

 

image007bv.jpg

Share this post


Link to post
Share on other sites

...and DONE!!

 

FYI, the awkward vibrations stopped after changing the seal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Welcome to NPORA Forums

 

Please register to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...