Jump to content

Atomicrider

Members
  • Content Count

    4
  • Joined

  • Last visited

Everything posted by Atomicrider

  1. On my 94 XE it’s on the wiper lever. It’s a twist ring next to the intermittent speed setting. Sent from my iPhone using Tapatalk
  2. Mine wasn’t too bad, but I did remove the torsion rod so that I could turn the nut on the control arm easier. Ordering the parts this week, hopefully get to replacing everything by the end of the month and I will report back. Sent from my iPhone using Tapatalk
  3. Thanks for the heads up on the rust potential and the tip on frame reinforcement. Everything seems pretty good in the rust department, but I’ll look it over. I’ll see if I can find rear link bushings and start changing those out next month. Sent from my iPhone using Tapatalk
  4. I’ve got a ‘94 XE that I’ve had for a couple of years that I have been getting road worthy again. It was pretty scary to drive down the highway so I just replaced all bushings in the front with urethane ones (uca and lca and sway bar) replaced CV joints, all ball joints, steering damper, and Rancho 9000 on all four corners. Had the alignment done and things are much better. But my back end seems to wiggle back and forth going over bumps. I have lifted the truck 2” with some blocks under the springs and have relocated the panhard bar the proper 2” as well. Any thoughts? Do I need to replace all of the bushings in the rear as well? Thanks. Sent from my iPhone using Tapatalk

Welcome to NPORA Forums

 

Please REGISTER to gain full access to the forum.

Make sure you read the Forum Guidelines and don't forget to post a new intro in the New People Start Here! section, to say hi too everyone.

 

-NPORA

×
×
  • Create New...