Jump to content

jtchal

Members
  • Posts

    67
  • Joined

  • Last visited

  • Days Won

    5

Everything posted by jtchal

  1. Nice! Shipping wouldn't have been cheap!
  2. Impressive! That's (or was) powered by a QD32Eti. Is it still running the stock diesel engine or any mods?
  3. Well I have no idea what happened but it seems to have gone away. So back to being happy with the shakey old beast...
  4. Hi guys This will be a bit of a long shot as I know our diesel R50s are a bit different to the more commonly available petrol models but I know they share the same 4 speed auto transmission. Has anyone had issues with their 4WD light 'taking out' the axle display and staying on constantly? I'm definitely in 2wd when starting the car as you can see in the video but the axle lights just go out... Keen to hear if anyone has come across something similar, I'm sure it's a very basic bad earth somewhere. https://imgur.com/XHq2N1I
  5. How much is that airbag system you're looking at? I doubt it'd be cheaper than a pair of LR coils. I'm pretty sure I got mine (LR9447) for less than NZ$150 shipped... I'd love to find an equivalent that's as cheap for the front coils.
  6. Well, I'm baffled. I thought I checked anything but somehow missed that one... Replaced it and on came the stereo, door chime and the antenna motor even started going! Thank you so much, you've just made my Sunday!
  7. Yep all 3 were cut at the same time, I've also checked the fuse on the back of the stereo which is intact, I've replaced it anyway. I've also noticed that i no longer get any beeping when I have the driver's door open with the key sitting in the ignition barrel (car off). Surely it's a bad earth connection somewhere...
  8. Hey team, is anyone still rocking a motorised antenna that works or has any experience tinkering with one? I tried to be cheeky and steal the one off my partner's R50 as the motor still sounded like it was operational on hers... So I've ordered a new mast which I was going to slot in there to give it a second chance. Today was D-day, so I went in pretty hot and cut the 3 wires that power the antenna motor, with the hope of soldering on the working one. Seemed like it would be a simple swap, however I've managed to kill both our stereos. So I've spent the day trying to see what was going on, testing and inspecting fuses both under the dash and behind the stereo but they were all fine. I also used my tester screw driver and established that I wasn't getting the constant 12v from the battery, however the 12v from the ACC came on just fine but the radio still refused to power up... Has anyone ever experienced something similar? Or any idea why the stereo would not power up/ 12v constant power isn't coming through?
  9. Hey mate, 31s should fit with the stock suspension setup. Had them on both my previous and current R50s. Looks like the Regulus you're looking at has 16" rims so you'll need to get the equivalent of 31s as they're only available for 15" rims. In terms of suspension changes between models, I think they only change between the 96-99 and 00-04 was the orientation of the rear shock mount. The others will correct me if I'm wrong though.
  10. Those 9449's will surely give you a decent amount of rake even if you get true 2" lift front coils. Keen to see the outcome though. Could you please measure the uncompressed length of the Pedders coils when you get them? As well as the coil thickness.
  11. Keen to see how you go with pedders mate. I recently went with some EFS front coils but I reckon they don't quite provide a true 2" lift... I've also heard from KiwiTerrano that his cobra springs sagged after not too long...
  12. I re-used mine even though it was split. On another note, keep up the photo updates, they're great!
  13. I had a look to see how much shipping the AC Coils to NZ would be, the total cost was 500+ USD... I don't think I'll ever be able to justify that purchase. I'm sure if they had a reseller here they would be selling a few, quite a few R50s on our roads still.
  14. Classy looking ride, what size tyres are you running by the way?
  15. Those Falken Wildpeaks look beastly! Do you have any any spacers up front or just the AC coils? Any weight in the boot? There looks to be very little rake and I'm jealous haha!
  16. I got the struts from Rockauto, coils from Australia and the strut mount assembly from Japan and all were shipped to NZ as parts are way overpriced here. Below is the breakdown of what I paid in NZ$ including the OEM part numbers for the strut mount parts, note that the strut bearings aren't on this list as I had purchased them earlier. So should be a lot cheaper for you since your dollar is stronger and OEM parts are cheaper in the states. Hope this helps!
  17. I just bit the bullet and replaced the whole strut mount assembly with OEM parts, well worth it.
  18. Hey @KiwiTerrano, do you still happen to have the photos of these recovery hooks? If so could you please upload them again? I'm keen to look at fabricating some but I'm a visual kinda person haha. I'm sure others would benefit from seeing them too!
  19. Niggly wait... But it will all be worth it, that bumper looks good on both R51 & R50 pathfinders! Only issue with the diesel R50's is the location of the intercooler and washer bottles/pump... You getting it from Opposite Lock? You'll probably need to certify the lift kit since it's greater than 2", keen to see what he says though.
  20. Looking forward to seeing that installed. What's the ETA with lockdown and all?
  21. Check your front sway bar bushes. I had some clunking which was driving me insane and it disappeared after replacing the shot stock bushes with some Nolathane ones! Cheap and easy.
  22. That's an impressive lift. I've got 9447s in the back and Australian made EFS 40mm (1.75"?) raised coils in the front, and I don't believe mine sits as high. Similar stance though. Looks like AC coils are the only ones to provide a 'true' 2" lift up front...
  23. Woah that thing is filthy! I like where you're going with it though!
×
×
  • Create New...